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Baiduri b.Digital Business is a digital platform which enables your business 
to access your accounts and perform various financial transactions.
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1 Login
1.1 Login Overview

Baiduri b.Digital Business 
is a digital platform which 
enables your business to 
access your accounts and 
perform various financial 
transactions. 

Companies and businesses will first need to be registered. Your company will be assigned a unique 
Corporate Group ID. One or more users can be created on for each organization on this platform 
along with their access permissions to various functions and accounts

After all individual IDs of the organization have been created, each company user will receive 2 
emails;

•	 The first email will contain the user’s Corporate Group ID, User ID and a link to login.
•	 The second email will contain the Temporary Password for first time activation.
•	 Use Digital token (generated via Baiduri b.Digital Business mobile app) or Physical token for 

the 2FA Authentication

There are 2 types of authentications:

•	 Digital Token (generated via Baiduri b.Digital Business mobile app) or
•	 Physical Token*
*Physical token is issued only upon request with charges

Once you have logged into the platform, you can perform certain functions depending on the
type of permission access you have been assigned, for example:

Initiate Transfers,
Bill Payments

Upload payment files

Manage Payees,
Manage Billers

Approve Transfers, Bill Payments

View latest balances of all
their company accounts

View current day transactions
of all their accounts

View and download account statements

View the execution status of the
payment instructions from the bank

Download the payment transactions
& statuses as reports

To view a video tutorial on how to log in, click here.

https://youtu.be/hSgLn4fTqUU
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1 Login
1.2 First Time Login

Receiving your Corporate Group ID, User ID and Password

Once the bank has created and activated your IDs, a notification will be sent to your registered 
email address to initiate the first-time login process. In the first email, you will receive your 
Corporate Group ID and User ID, and in the second email, you will receive a Temporary Password. 
Please check in your spam/junk mail if you have not received the emails.

First time registration for Digital Token

Download the Baiduri b.Digital Business mobile app from Google Play (for Android Users) or 
AppStore (for iOS Users).

Once installed, you will need to key in your Corporate Group ID, User ID and Temporary
Password in the login screen, then click Proceed to Login.

Step 1

Step 2

*Please ensure that the temporary password received is entered correctly. For example, the number ‘1’ and the small letter ‘l’ 
can be easily mistaken for each other.
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1 Login
1.2 First Time Login

Select the 2FA verification type you prefer for your one-time PIN (OTP), either SMS or
email.

Key in the OTP you’ve received on the verification page on the Baiduri b.Digital Business
mobile app.

Step 3

Step 4

Sample of SMS OTP

Sample of Email OTP
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1 Login
1.2 First Time Login

A pop-up message will appear prompting you to change your password. This step is
mandatory.

Step 5

Step 7

Step 6

Enter your newly set password.
 
Password must be 8 to 12 characters long and contain at least one number, one uppercase letter, 
one lowercase letter, and one special character. Only the characters !@#$%^ are accepted.

Tap Change Password
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1 Login
1.2 First Time Login

You should receive a “Success” pop up on the screen. This confirms that have
successfully set up your Digital Token.

Tap OK to proceed. You will then be logged out of the session and redirected back to
the homepage of the mobile app.

Important Note:

Users with multiple user IDs with different companies will need to login with each Org ID 
to create a new password for each organization.  

Step 8

Step 9

You should receive a “Success” pop up on the screen. This confirms that have
successfully set up your Digital Token.

Step 8
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1 Login
1.2 First Time Login

First time registration for Physical Token

Go to www.baiduri.com on your web browser then click the LOGIN button.

Under the LOGIN panel, click on Baiduri b.Digital Business

You should see the screen below.

Step 1

Step 2

Step 3
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Enter your Corporate Group ID, User ID and Temporary Password.

Click the PROCEED TO LOGIN button to continue. You will then see the Two Factor Authentication 
(2FA) screen as shown below. 

Step 4

Step 5

1 Login
1.2 First Time Login
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On your physical token, press the Power button, followed by Number 1, to generate a 6-digit code. 
Enter the code shown into the 2FA screen, and then click SUBMIT.

After that, you will be directed to the Force Password Change screen.

Force Password Change screen

Step 6

Step 7

1 Login
1.2 First Time Login
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Enter the New Password in the respective field.

Password must be case sensitive and must contain Alpha 
Numeric with 1 UPPERCASE and 1 Special character and length 
should be 8-12 characters. Only the characters !@#$%^ are 
accepted.

Step 8

Click SUBMIT. You will get logged-out of the session and directed to the homepage.

Re-enter the new password in Confirm Password field.

Step  9

1 Login
1.2 First Time Login

 	 Both New and Confirm password should be matched.
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1 Login
1.3 Login via website 

Step 1

Under the LOGIN panel, click on Baiduri b.Digital Business.

Step 2

Go to 	     www.baiduri.com on your web browser and click the LOGIN button.
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1 Login

Enter your Corporate Group ID, User ID and newly changed Password in the login screen

Click the PROCEED TO LOGIN button.

You will then be lead to the Two Factor Authentication (2FA) screen.

Step  3

Step  4

Step  5

Login for Business Banking screen

1.3 Login via website 
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1 Login

Step 6

Open the mobile app and
click on the 3-line icon at the
top left corner of the app

On the menu panel, tap on
‘Generate Secure Code’

The Secure Code will appear
on your screen

1.3 Login via website 

To log in with the Digital Token, follow these steps to generate the Secure Code from the Baiduri 
b.Digital Business mobile app.
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1 Login
1.3 Login via website 

If you have multiple IDs, after clicking on Generate Secure Code, you will need to choose the 
Organisation from the screen below to generate the secure code.

To log in using the physical token, press the Power button followed by number 1 to generate the 
6-digit OTP. Then enter the code on the screen.
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1 Login
1.3 Login via website 

Enter the 6-digit Secure Code to the 2FA screen.

Tap Submit. You will then be directed to the dashboard of the Baiduri
b.Digital Business platform.

Step  7

Step  8

Two Factor Authentication (2FA) 

Dashboard Screen

To view a video tutorial on how to log in, click here.

https://youtu.be/hSgLn4fTqUU
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1 Login
1.4 Forgot Password 

Reset Password

If you have forgotten your password, you can reset it via the Baiduri b.Digital Business login page.

Step 1

Step 2

Click Forgot Password link on the Login page.

You will be led to the Forgot Password screen. Enter the valid Corporate Group
ID, User ID, and Registered Email ID.

Login for Business Banking screen

Forgot Password Screen
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1 Login

Click GENERATE PASSWORD

The One Time Password screen should be displayed

Step  3

Step  4

One Time Password (OTP) screen

1.4 Forgot Password 
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1 Login

From the drop-down arrow, select the 2FA type you prefer, i.e. SMS OTP or email OTP and click 
SUBMIT.

Once you’ve clicked SUBMIT, the temporary password will be sent to your registered email ID.

Step 5

Step  6

Step  7

Step 8 

Then go to the login screen and enter your Corporate Group ID, User ID and temporary password 
(that you’ve received in your registered email address).

You will be be redirected to the Change Password screen. 

1.4 Forgot Password 
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Click SUBMIT. You will be logged out of the session and redirected to the homepage.

Password is case sensitive and must contain alpha numeric with at least 1 UPPERCASE, 1 special 
character and length should be 8 to 12 characters.

Both New and Confirm password should match.

1 Login

Enter your new password twice in the New Password and Confirm Password fields.

Step  9

1.4 Forgot Password 

Click Yes to Log out

Logout

Click Logout and you will be asked to confirm your decision.
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2 Dashboard
2.1 Dashboard Overview

The main page, also known as the
Dashboard of the Baiduri b.Digital Business 
platform provides an overview of your accounts, 
including consolidated reports of both financial 
and non-financial transactions.
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The Financial Summary page provides a snapshot of your company’s latest account 
balance, including Account Number, Account Short Name and Available Balance.

You can also view other companies linked to your organization by selecting the company name 
from a drop-down list at the Choose Company field.

Note:
The pie chart represents the total amount in each type of currency. See below for illustration.

When you click VIEW ALL, you will be directed to the Accounts menu to view more information 
under the linked accounts.

2 Dashboard
2.2 Financial Summary
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The Financial and Non Financial transaction statistics table depicts the overall status of 
transactions performed on the platform. You can filter information you wish to view by date.

Transactions under Financial and Non-Financial are listed as below:-

2 Dashboard
2.3 Financial & Non Financial Transaction Statistics

NON-FINANCIALFINANCIAL

• Acceptance of Discrepancy
• Bank Guarantee
• Batch Transfers
• Bill Payment Standing Instruction
• Bill Payments
• Irrevocable Letter of Credit
• Letter of Credit Amendment
• Payroll
• Shipping Guarantee
• Single Payment Transfers
• Shipping Guarantee

• Account Sweep
• Beneficiary
• Biller Payee
• Cheque Book
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User Workflow – details of transactions and the overall status count of the transactions. 
Bank Workflow – transactions that have been sent to the Bank for processing.

Status Definition

2 Dashboard
2.3 Financial & Non Financial Transaction Statistics

Status

Status

Description

Description

USER WORKFLOW

BANK WORKFLOW

A transaction that has completed all approvals

Payments that failed during processing

A transaction that is not yet submitted for approval but is currently 
saved as a draft

Any future dated transactions that have been set up 

Transactions that have been deleted

Payments that have been successfully processed

Transactions with insufficient or incorrect details 

Any future dated transactions which have been stopped before the value date 

Transactions that are submitted for approval 

Files that have been uploaded where partial files failed during processing

Transactions that are pending further approval 

Transactions that have been sent for the Bank’s action

Any future dated transactions that have been stopped before the value date 

Transactions that have been rejected by an Approver

Transactions that have been sent back for repair.
The Maker will need to take action.

Failed transactions due to a system error

Fully Approved

Failed

Draft

Future Date

Delete

Success

Incomplete

Stopped

Pending Approval

Processed with Failures

Partially Approved

Send To Bank

Stopped

Rejected

Pending Repair

Release Failed
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Inbox
This is where you’ll receive transaction alert messages including Subject, 
Description and Date in the Inbox section.

2 Dashboard
2.4 Inbox/View Notification/Send Message

Notification 
To view notifications for your transactions and requests from the bank, 
click on the bell icon       in the upper right corner. 

To view more information about each notification sent, 
click on the individual message subject link.
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2 Dashboard
2.4 Inbox/View Notification/Send Message

Send Message
To send a message to the E-Banking Customer Service, click on the Mail icon
on the upper right corner .

Click on Create New. A New Message screen will be prompted.

From the drop-down list, select the Category. Enter a Subject, then type your Message 
in the respective fields.

Click SEND to send the message to the bank. 
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You can also customize your profile picture and name within your account. 
You may also view your last login details.

Click the Edit icon      .
The Update Profile Picture window should be displayed.

Click Browse to choose an image you want to upload. 

2 Dashboard
2.5 Customizing Profile Image and Name

Important notes
• Image file size cannot exceed 4MB
• Image file format must be JPEG and PNG only
• Enter your preferred display name in Profile Nick Name field
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3 Accounts

This section allows the assigned users to view the company’s Accounts, Limits, Loans, Overdrafts, 
Letter of Credit, Trust Receipt, Inwards Collections, Guarantee, Forex, Hire Purchase and Corporate 
Cards (if any).

3.1 Overview



31 Baiduri b.Digital Business User Guide

3 Accounts
3.2 Accounts Overview Function

On the Accounts Overview screen, you can access information such as Operating Account,

Deposit Account and Loan Account. You can view same day transactions of all accounts as

well as the latest balances of all accounts.

What each user is able to view depends on the type of access and permissions assigned to

them. For example, User 1 can view all accounts, however, User 2 will only be able to view

selected accounts.

Under the menu, go to Accounts → Accounts Overview.

Figure 1: Accounts Overview screen
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3 Accounts
3.2 Accounts Overview Function

Functions available under the Beneficiary List screen.
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3 Accounts
3.2 Accounts Overview Function
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3 Accounts
3.3 Operative Accounts

Under Operative Accounts, you can view the balances of accounts as well as the consolidated

balances. You can also sort and view account details through the fields provided.

Under the menu, go to Accounts → Operative accounts.. You should see the list of available

Operative Accounts

Figure 4: Operative Accounts screen
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3 Accounts
3.3 Operative Accounts

Click on the Account Number of the account you wish to review. You will be able to view more

details under that account.
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3 Accounts
3.3 Operative Accounts

To view and review each account’s past transactions, click on the Transaction History tab.

You can choose to review past transactions by a specific period. Click the Calendar icon, then

select the date range of the transactions they wish to review. Once set, click VIEW 

TRANSACTIONS. The requested details will be displayed on the screen.
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3 Accounts
3.3.1 Searching Specific Operative Accounts

You can look for specific operative accounts with the Search Operative Accounts function

through the Company, Account Type, Account Number or Currency from the respective

fields.

Step 1

Select or enter information from any of the respective fields, i.e. Company, Account
Number, Account Type or Currency.

Figure 5: Operative Accounts screen
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Step 2

Click SEARCH. The requested details will be displayed on the screen.

Figure 6: Operative Account Inquiry screen

3 Accounts
3.3.1 Searching Specific Operative Accounts
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Step 3

Click on the Account Number you wish to review to view more details. You should see
more details on that account.

Figure 7: Operative Accounts screen

3 Accounts
3.3.1 Searching Specific Operative Accounts



Baiduri b.Digital Business User Guide 40

3 Accounts
3.4 Deposit Accounts

Step 1

From the menu, go to Accounts → Deposit Accounts. You should see the list of
available Deposit Accounts.

Figure 7: Operative Accounts screen
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3 Accounts
3.4 Deposit Accounts

Step 2

Click on the Account Number you wish to review to view more details. You should see
more details on that account.
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3 Accounts

You can also search for specific deposit account entries through Company, Account Number or

Currency.

Step 1

Select or enter information from any of the respective fields, i.e. Company, Account
Number, Account Type or Currency.

Figure 5: Operative Accounts screen

3.4.1 Searching Specific Deposit Accounts
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Step 2

Click SEARCH. The requested details will be displayed on the screen.

3 Accounts
3.4.1 Searching Specific Deposit Accounts
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3 Accounts
3.5 Loan Accounts Overview

You can also view the loan accounts your company has with Baiduri Bank.

From the menu, go to Accounts → Loan Accounts Overview.

Figure 9: Loan Account Overview screen
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From the menu, go to Accounts → Loan Accounts Overview.

3 Accounts
3.5.1 View - Loan Accounts
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Loan Accounts

Click on the Account Number you wish to review to view more details. You should see
more details on that account.

Note: ‘P’ in Interest Rate denotes Prime Lending Rate of 5.5% and is subject to change.

Disclaimer: For Past Due status, the default interest will apply. Please refer to your Facility Offer
Letter (FOL) for more details.

3 Accounts
3.5.1 View - Loan Accounts
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Trust Receipt

From the menu, go to Accounts → Loan Accounts Overview → Trust Receipt

Click the Limit Reference hyperlink of the record to view each field of the selected record.

Note: ‘P’ in Interest Rate denotes Prime Lending Rate of 5.5% and is subject to change.

Disclaimer: For Past Due status, the default interest will apply. Please refer to your Facility Offer
Letter (FOL) for more details.

3 Accounts
3.5.1 View - Loan Accounts
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Hire Purchase

From the menu, go to Accounts → Loan Accounts Overview → Hire Purchase Details

Click the Account Number of the Hire Purchase Account where to view more details of
the Hire Purchase.

3 Accounts
3.5.1 View - Loan Accounts
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Step 1

Step 2

Click PAY. This corresponds with Pay Monthly Instalment / Pay Charges / Pay Insurance.
You should be directed to a Create Payment screen.

Under the Initiate Payment section, enter the Applicant Details, Biller Information and
Payment Details.

(Refer to Bill Payment for a more detailed guide) Bill Payee Management

3 Accounts
3.5.2 Hire Purchase - Pay Monthly Instalment/
	 Charges/ Insurance
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Initiate Payment

Step 1

Step 2

Click PAY. This corresponds with Pay Monthly Instalment / Pay Charges / Pay Insurance.
You should be directed to a Create Payment screen.

Under the Create Payment screen, enter the relevant details under the Applicant section.

3 Accounts
3.5.2 Hire Purchase - Pay Monthly Instalment/
	 Charges/ Insurance
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Step 3

Under Create Payment, the Biller Information is auto-populated from the Hire Purchase screen.

Edit/View Adhoc Bill Payee

Click Edit/View Adhoc Bill Payee.
The Bill Payee Information screen 
should be displayed. You will only 
be able to edit the Payee Nick 
Name field.

(For more detailed information, refer to 
Bill Payee Management)

Figure 10: Edit/View Adhoc Bill Payee screen

Bill Payee Management

3 Accounts
3.5.2 Hire Purchase - Pay Monthly Instalment/
	 Charges/ Insurance
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Step 3

Under the Payment Details section of Create Payment screen, the Debit Currency,
Payment Currency, Bill Amount, Payment Amount and Debit Amounds fields are autopopulated.
However, the Payee Nick Name and Remarks fields will need to be filled.

3 Accounts
3.5.2 Hire Purchase - Pay Monthly Instalment/
	 Charges/ Insurance
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Review

Click CONTINUE. The Review screen should be displayed where you can review the information 
you have entered.

Click PROCEED TO SUBMIT to confirm the details.

3 Accounts
3.5.2 Hire Purchase - Pay Monthly Instalment/
	 Charges/ Insurance
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Complete

A confirmation message should be displayed and the details will be submitted for approval
under Bill Payment. 

Under Bill Payment, you will be able to approve, reject or make amendments.

3 Accounts
3.5.2 Hire Purchase - Pay Monthly Instalment/
	 Charges/ Insurance
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On the menu, go to Accounts → Corporate Cards.

To view your credit card transaction details, click on the Card Number.

3 Accounts
3.6 Corporate Cards

For more information on how to pay for your credit cards, refer to Bill Payment section.

Bill Payee Management
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Download Transaction Details

3 Accounts
3.6 Corporate Cards

Step 1

Step 2

From the drop-down list, select your preferred file format, i.e. PDF or CSV.

Once you’ve selected the file format, click DOWNLOAD.

You should then have access to a transaction report in your preferred format.

Step 2
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Under Limits Summary, you will be able to review your company’s overall limits, i.e. Letter of
Credit, Trust Receipt, ML General, Performance Bond, Corporate Loan, Revolving Loan,
Guarantee, Overdraft and Forex.

From the menu, go to Accounts → Limits Summary. On the Limits Summary screen, click on
the Limit Reference link to view more details.

3 Accounts
3.7 Limit Summary
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Guarantee Summary summarizes the company’s Guarantee details.

Overdraft Summary allows assigned users to view the company’s Overdraft limit.

Letter of Credit (LC) summarizes the company’s LC limits.

3 Accounts
3.7 Limit Summary
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Trust Receipt summarizes the company’s TR limits.

Forex Summary summarizes the company’s Forex contracts.

3 Accounts
3.7 Limit Summary

Note: ‘P’ in Interest Rate denotes Prime Lending Rate of 5.5% and is subject to change.

Disclaimer: For Past Due status, the default interest will apply. Please refer to your Facility Offer
Letter (FOL) for more details.
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From the menu, go to Accounts → Bill Collections.

3 Accounts
3.8 Bill Collections
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4 Transfers
4.1 Transfers Overview

Under the Fund Transfers section, you can do several types of transactions, including:

•  Fund Transfers
- Internal Transfer – transfers within your own company accounts in Baiduri Bank
- Domestic – Same Bank – transfers to a third party within Baiduri Bank
- Domestic – Other Bank – transfers to another local bank
- Telegraphic Transfer – transfers to an overseas bank

•  Payments – create single, adhoc and batch
•  Standing Instructions – create, amend and delete
•  Approve transactions under Manage Workflow (for Approvers only)

You also have the option to make transfers immediately, at a future date or 
periodically by setting up standing instructions.
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4 Transfers
4.2.1 Create Single Payment (Internal Transfer)

This feature allows you to transfer funds to other accounts within your company group.

From the menu, go to Transfer → Create Single Payment.
The Create Transfer screen should be displayed.

Application section

Fields

Enter your Company Reference

Under the drop-down list, there are 3 options, Internal, 
Domestic and International transfers

Select the Company you wish to transfer the funds to

Depending on the company chosen under the 
Choose Company field, respective accounts linked 
to that account will be auto-populated

Enter the date that you prefer the payment to be released.

If the Payment Date falls on a non-working day, then the 
transaction will be carried out the next working day.

Payment Method

Your Reference

Pay From

Choose Company

Payment Date

Mandatory

Mandatory

Mandatory

Mandatory

Mandatory

Description Mandatory/Optional
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4 Transfers
4.2.1 Create Single Payment (Internal Transfer)

Choose Your Own Company Account

Amount

Fields

Fields

Enter the amount you wish to transfer

This will be set by default based on the currency of the 
selected Pay From account

Select the account you want the funds to be transferred to

This will be set by default based on the currency of the 
selected Pay To account

Pay To

Payment Currency

Transfer To Company

Debit Currency

Mandatory

Mandatory

Mandatory

Mandatory

Description

Description

Mandatory/Optional

Mandatory/Optional
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4 Transfers
4.2.1 Create Single Payment (Internal Transfer)

Fields

If the Pay To currency and Pay From currency are different, 
an Amount Priority field will appear. 

Enter the amount to pay based on the currency of 
the Pay To account.

Debit Amount

Payment Amount

Mandatory

Mandatory

Description Mandatory/Optional

Amount Priority
Debit Amount – debits the amount based on the Debit 
Currency or Pay From account

Payment Amount – pays the currency based on the 
Pay To account 
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4 Transfers
4.2.1 Create Single Payment (Internal Transfer)

Payment Information

Review
After clicking the CONTINUE button, the Review screen will be displayed. You can verify 
inputted details here.

Complete
To complete the transaction, click the PROCEED TO SUBMIT button. A confirmation message 
will be prompted and the request will be submitted for approval.

Other fields

Fields

Actions

Enter details or remarks of any instructions for the bank

Save a draft of what you’ve entered before submitting it for approval.

Enter additional information, if any

Allows you to re-create the same transfer without needing to 
repeat the whole process again.

Enter any additional remarks, if any

For non-straight through processing transactions (non-STP), payments 
may incur delays as they will be processed through the service desk.

Instruction 
to Bank 
(Line 2)

Save as Template

Payment 
Remarks

Instruction 
to Bank

Save as Draft

Optional

Optional

Optional

Description

Response

Mandatory/Optional

This payment may experience a delay in settlement as it is processed manually
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Applicant

This feature allows you to transfer funds to other third-party accounts 
within Baiduri Bank as well as other local banks.

From the menu, go to Transfer → Create Single Payment.
The Create Transfer screen will be displayed.

Fields

Enter your Company Reference 

From the drop-down list, select Domestic

Select the Company you wish to transfer the funds to

Depending on the company chosen under the 
Choose Company field, respective accounts linked 
to that account will be auto-populated

Enter the date that you prefer the payment to be released.

If the Payment Date falls on a non-working day, then the 
transaction will be carried out the next working day.

Payment Method

Choose Company

Pay From

Payment Date

Your Reference Mandatory

Mandatory

Mandatory

Mandatory

Mandatory

Description Mandatory/Optional

4 Transfers
4.2.2 Create Single Payment (Domestic Transfer)
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Beneficiary

4 Transfers
4.2.2 Create Single Payment (Domestic Transfer)

Fields

Same Bank – transfers the payment to another beneficiary 
account within Baiduri Bank 

Other Bank – transfers the payment to another beneficiary 
at another local bank 

Transfer To
• Same Bank
• Other Bank

Mandatory

Description Mandatory/Optional
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4 Transfers
4.2.2 Create Single Payment (Domestic Transfer)

Fields

Pay To Mandatory

Description Mandatory/Optional

Under Other Bank, the Payment Reference selection will 
be displayed.

Automated Clearing House (ACH) 
Recommended for payments such as salary transfers, 
sending funds to friends and family, etc

Real-Time Gross Settlement (RTGS)
Recommended for larger amount transfers and payments 
that need to be settled urgently.

Requests submitted after the cut-off times, Sunday and 
public holidays will be processed on the next working day.

Click on the Pay To field. The Search Beneficiary screen will 
be displayed. You can then select the Beneficiary Name, 
Account Number, Bank and Branch that was created 
under Beneficiary Management.
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4 Transfers
4.2.2 Create Single Payment (Domestic Transfer)

Fields

Create Adhoc 
Beneficiary

Description Mandatory/Optional

You can create an Adhoc Beneficiary if the intended 
beneficiary has not yet been created under Beneficiary 
Management. Fill in their details in the fields below.
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4 Transfers
4.2.2 Create Single Payment (Domestic Transfer)

Amount Section

Fields

Mandatory

Mandatory

Mandatory

Description Mandatory/Optional

This field is auto-populated based on the currency of the 
selected Pay From Account 

This field is auto-populated based on the currency of the 
Pay To Account 

If the Debit Currency differs from the Payment currency, an 
alert message will be prompted. Click OK to proceed with 
the transaction.

This field has two options, select one:

Debit Amount – To debit the amount based on the 
Debit Currency

Payment Amount – To pay the Pay To account based 
on their currency

Debit Currency

Payment Currency

Amount Priority
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4 Transfers
4.2.2 Create Single Payment (Domestic Transfer)

Fields

Debit Amount

Payment 
Amount

Description Mandatory/Optional

If the Pay To account currency differs from the Pay From 
account, this field will appear.

Enter the amount to pay based on the currency of the Pay 
To account.

Mandatory
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Payment Information section

Fields

Optional

Optional

Optional

Description Mandatory/Optional

Enter any details that you would like to leave for the bank 
to take note of

Enter any additional information if needed

Enter any remarks you would like to leave with the 
payment transaction.

For non-STP transactions, payments will be processed 
through the service desk and may experience delays.

Instruction to Bank

Instruction to Bank 
(Line 2)

Payment Remarks

4 Transfers
4.2.2 Create Single Payment (Domestic Transfer)

Review
After clicking the CONTINUE button, the Review screen will be displayed. You can verify 
inputted details here.

Complete
To complete the transaction, click the PROCEED TO SUBMIT button. A confirmation message 
will be prompted and the request will be submitted for approval.

Other fields

Actions

Save a draft of what you’ve entered before submitting it for approval.

Allows you to re-create the same transfer without needing to 
repeat the whole process again.

Save as Template

Save as Draft

Response
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4 Transfers
4.2.2.1 Create Single Payment (Adhoc Beneficiary)

Transfer funds to a Beneficiary account and create the Beneficiary in the 
same transaction for local and overseas Fund Transfers.

From the menu, go to Create Transfer → Beneficiary.
The Beneficiary screen should be displayed.

Click Create Adhoc Beneficiary. A Create Adhoc Beneficiary screen should be displayed. 

Refer to Beneficiary Management guide for more detailed guide.
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4 Transfers
4.2.3 Create Single Payment (International Transfer)

From the menu, go to Transfer → Create Single Payment.
The Create Transfer screen should be displayed.

Applicant section

Fields

Mandatory

Mandatory

Mandatory

Mandatory

Mandatory

Description Mandatory/Optional

Enter your Company Reference

From the drop-down list, select International Transfer

Select the Company you wish to transfer the funds to

Depending on the company chosen under the Choose 
Company field, respective accounts linked to that account 
will be auto-populated

Enter the date that you prefer the payment to be released.

If the Payment Date falls on a non-working day, then the 
transaction will be carried out the next working day.

Your Reference

Payment Method

Choose Company

Pay From

Payment Date
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4 Transfers
4.2.3 Create Single Payment (International Transfer)

Beneficiary fields

Fields

Mandatory

Description Mandatory/Optional

Click on the Pay To field. The Search Beneficiary screen will 
be displayed. You can then select the Beneficiary Name, 
Account Number, Bank and Branch that was created 
under Beneficiary Management.

You can create an Adhoc Beneficiary if the intended 
beneficiary has not yet been created under Beneficiary 
Management. Fill in their details in the fields below.

Pay To

Create Adhoc 
Beneficiary
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4 Transfers

Amount section

Fields

Mandatory

Mandatory

Mandatory

Description Mandatory/Optional

This field is auto-populated based on the currency of the 
selected Pay From Account 

This field is auto-populated based on the currency of the 
Pay To Account

If the Debit Currency differs from the Payment currency, an 
alert message will be prompted. Click OK to proceed with 
the transaction.

This field has two options, select one:

Debit Amount – To debit the amount based on the 
Debit Currency

Payment Amount – To pay the Pay To account based 
on their currency

Debit Currency

Payment Currency

Amount Priority

4.2.3 Create Single Payment (International Transfer)
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4 Transfers

Fields

Mandatory

Mandatory

Description Mandatory/Optional

If the Pay To account currency differs from the Pay From 
account, this field will appear.

Enter the amount to pay based on the currency of the Pay 
To account 

The selection on this field will determine who bears the cost of 
the transfer fees.

• Beneficiary – this means that the beneficiary will bear the cost
• Sender – this means that the sender will bear the cost
• Shared – this means that the cost will be shared between the

beneficiary and the sender

Debit Amount

Payment Amount

Charges Borne By

Payment information fields

4.2.3 Create Single Payment (International Transfer)
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4 Transfers

Fields

Optional

Optional

Optional

Description Mandatory/Optional

Enter any details that you would like to leave for the bank 
to take note of

Enter any additional information if needed

Enter any remarks you would like to leave with the 
payment transaction.

For non-STP transactions, payments will be processed 
through the service desk and may experience delays.

Instruction to Bank

Instruction to Bank 
(Line 2)

Payment Remarks

Under the Declaration section, you will need to select the Purpose of payment 
from a drop-down list.

Review
After clicking the CONTINUE button, the Review screen will be displayed. You can verify 
inputted details here.

Complete
To complete the transaction, click the PROCEED TO SUBMIT button. A confirmation message 
will be prompted and the request will be submitted for approval.

Other fields

Actions

Save a draft of what you’ve entered before submitting it for approval.

Allows you to re-create the same transfer without needing to 
repeat the whole process again.

Save as Template

Save as Draft

Response

4.2.3 Create Single Payment (International Transfer)

This payment may experience a delay in settlement as it is processed manually
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4 Transfers
4.3 Create Batch Payment

In this section, you can create batch payments for internal, domestic and 
international transfers. Approvers can also approve transfers in one go.

From the menu, go to Transfer → Create Batch Payment.
The Create Batch Payment screen should be displayed.

A Batch reference number will be generated.

Enter all necessary information as required for a transfer.

Click the SAVE CRITERIA button. The application will save the Batch Criteria Selection.
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4 Transfers
4.3 Create Batch Payment

The Payment Details screen 

Enter all necessary information as required for a transfer.

Click the ADD PAYMENT button. The payment details will appear.
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4 Transfers
4.3 Create Batch Payment

Add Payment functions

Once all the details are filled, click the CONTINUE button.
The Review screen will then be displayed.

Action Response

Expand (     ) icon and click Edit option, the records under the 
ADD Payment details can be edited and submitted for approval

Expand (     ) icon and click Delete option, the records under the 
ADD Payment details can be deleted

Edit

Delete
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4 Transfers
4.3 Create Batch Payment

Review
Review and confirm the inputted details before submitting for approval.

Complete
Click PROCEED TO SUBMIT. A confirmation message should be prompted and 
the request is submitted for approvals.

You can create another batch of payments by clicking Create Another Batch Payment.
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4 Transfers
4.4 Create Transfer Standing Instruction

In this section, you can create domestic transfers standing instructions.

From the menu, go to Transfer → Create Transfer SI.
The Create Standing Instruction screen should be displayed.

Enter details in the required fields. You will need to create an SI Nick Name.
This is for your own reference so that you can easily identify the account.

Under Beneficiary and Amount sections, enter details as per a normal Transfer.
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4 Transfers
4.4 Create Transfer Standing Instruction

Standing Instruction Information section

Fields

Mandatory

Mandatory

Mandatory

Description Mandatory/Optional

From the drop-down list, select how often you would like 
to pay the standing instruction

Set the date of when the payments should start

Set how many times the payment should occur

Frequency

Start Date

Number of 
Occurrence

Review
Click CONTINUE. The Review screen should be displayed.

Complete
Click PROCEED TO SUBMIT. A confirmation message will be displayed and the 
request is submitted for approval.
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4 Transfers
4.5 Template

Create a template of the same transaction and reuse the template when performing 
a similar transaction in the future. This saves you time. When creating the template, 
you can save the template for future use. 

Once all details of the transactions are filled, click the Save as Template button.
A pop-up display will appear.

Template Reference – this reference is auto-generated
Template Name – this is where you can give the template a reference name
Template Access – there are 2 options, Private or Public

Public - can be accessed and used by users within the company group.
However, modification can only be done by the maker who created it.
Private - can be accessed by the maker who created it

Click the Save button to save the template. 
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4 Transfers
4.6 Edit/Delete/Amend Transfer

Edit, delete and amend a transfer that is sent back for repair by the Approver. 

From the menu, go to Transfers → Manage Workflow.
The Manage Workflow screen should be displayed. You can select either Single Payment, 
Batch Payment, Standing Instruction or Template under Filter Transaction.

Under the Action column, click the drop-down arrow, a submenu containing 
Edit and Delete option should be displayed.

Click Edit. For requests that were sent back for repair, you will be able to view the reason of 
why the request was sent back.
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4 Transfers
4.6 Edit/Delete/Amend Transfer

Click CONTINUE. The Review screen will be displayed where you can confirm 
the updated details.

Click PROCEED TO SUBMIT. The transaction will be sent back to the approver.  
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4 Transfers
4.6.1 Copy Active Transfer Records

Transactions that have been approved cannot be edited. You can copy details to be a 
template and change the payment amount.

From the menu, go to Transfers → Manage Transfers.
The Manage Transfers screen will be displayed.

Under the Action column, click the drop-down arrow. The application displays a sub-menu 
containing the Copy option.



89 Baiduri b.Digital Business User Guide

4 Transfers
4.6.1 Copy Active Transfer Records

Click Copy. The Copy Transfer → Applicant screen is displayed.

Choose your own company account and Payment Information are copied from the 
selected Single Transfer record. However, you will need to enter the Amount Details.

Once you’ve entered the required details, click CONTINUE. The Review screen is 
displayed where you can confirm the updated details.

Click PROCEED TO SUBMIT. A confirmation message is prompted and the updated 
request is submitted for approval.
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4 Transfers
4.7.1 Manage Transfer (Viewing Manage List)

Once a Transfer is approved, the details will be sent to the Manage Transfers List.

Click Manage Transfers. The Manage List screen is displayed, where you can view the 
list of Transfers and their corresponding status.

Click the PAYMENT REFERENCE link of the record where the user can view each field 
of the selected record as shown below.
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4 Transfers
4.7.2 Amendment/Deletion of Standing Instruction

This section specifies how you can delete a standing instruction.

Under the menu, go to Transfer → Manage Transfers. The Manage Transfers screen 
should be displayed. You can view the list of transfers and their statuses in this screen.

From the Filter Transaction field, select Standing Instruction. The list of Standing 
Instruction transfers should be displayed.

Under the Action column, click the drop-down arrow and select to either Edit or Delete.
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4 Transfers
4.8 Approver Flow (Transfers)

An Approver can approve, reject or send for repair for all records.
Below explains the transaction status:

Pending Approval
When the Maker has created the Transfer Payment Record and has submitted the request 
for approval.

Partially Approved
Payment record gets approved from one level of Approver and pending for approval from 
other Approvers.

Fully Approved
When payment has completed all the levels of approvals and is awaiting release.

To view a video tutorial on approving transactions, click here.

https://youtu.be/6V47d_c2Bmc
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4 Transfers
4.8.1 Approving Transfers

From the menu, go to Transfer → Manage Workflow.

The Manage Workflow screen should be displayed.

Under the Action column, click the drop-down arrow.
The application displays the sub-menu containing Approve, Reject and Amendment.
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Click APPROVE. Here the 2 Factor Authentication (2FA) screen will be shown and 
requesting the verification. 

Authentication screen reference

Click SUBMIT. The Transfers is approved and a confirmation message is prompted.
Once payment is approved, the details will be sent to the Manage List.

Click Approve. The Approve Transfer screen will be displayed, where you can verify 
the updated information.

4 Transfers
4.8.1 Approving Transfers
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4 Transfers
4.8.1 Approve (Transfers)

If approval of a transaction fails due to technical issues, the transfer will roll back to 
Release Failed status. You can then select whether to resubmit for approval or to 
cancel the release.

You can view transactions by generating the report under Account Balance Report



Baiduri b.Digital Business User Guide 96

4 Transfers
4.8.2 Amending and Rejecting Transfers

From the menu, go to Transfer → Manage Workflow. 
The Manage Workflow screen should be displayed.

Under the Action column, click the drop-down arrow.
The sub-menu containing Approve, Reject and Amendment should be displayed.
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4 Transfers
4.8.2 Amending and Rejecting Transfers

Select either Amendment or Reject, the Send To Amendment or Rejection screen will be 
displayed. You will need to input the reason in the Remarks field. 

After a transaction is sent for repair or rejected, it goes back to the Maker’s workflow 
and they receive an email notification.
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5 Bill Payment
5.1 Overview

This service allows you to pay various types of bills, including:

•	 Baiduri Bank credit cards
•	 Baiduri Finance Hire Purchase
•	 Utility bills (water and electricity)
•	 Phone bills (DST, imagine and Progresif)
•	 Other bills (Insurance, fees, taxes and etc)

In this section, there are 3 ways you can make bill payments:

Immediately

Future dated
you will need to specify the future date of 
when you prefer for the payment to be made

Standing instructions
you will be able to set up regular or
recurring payments
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5 Bill Payment
5.2 Create Bill Payment

From the menu, go to Bill Payments → Create Payment.

You can save the information you have entered as a draft before submitting the transaction.
The saved information can be reviewed again under Manage Workflow → Draft.

Functions under Bill Payment
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5 Bill Payment
5.2 Create Bill Payment

Biller Information field functions
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5 Bill Payment
5.2 Create Bill Payment

Functions under Bill Payment
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5 Bill Payment
5.2 Create Bill Payment
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5 Bill Payment
5.2 Create Bill Payment

If the set payment date falls on a weekend or public holiday, then the transaction will be
processed the next business day.

Review

Click CONTINUE. The request will be submitted and the Review screen will be displayed.
From here, you can review the entered details before submitting for approval.
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5 Bill Payment
5.2 Create Bill Payment

Complete

Click PROCEED TO SUBMIT. A confirmation message will be prompted. This means that the
transaction has been submitted for approvals.
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5 Bill Payment
5.3 Adhoc Payment

You can create payment profiles through Adhoc Payment to pay bills instantly. These profiles will
be saved as a Bill Payee which then can be viewed again under Biller Beneficiary.
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5 Bill Payment
5.4 Create Standing Instruction 

From the menu, go to Bill Payment → Create Payment SI
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Biller Information field functions

5 Bill Payment
5.4 Create Standing Instruction 
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5 Bill Payment
5.4 Create Standing Instruction 

Amount fields functions

Standing Instruction Information fields functions

Figure 1: Create Payment SI screen
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5 Bill Payment
5.4 Create Standing Instruction 
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Review

Once all the details were filled, click CONTINUE. The details will be displayed in the Review
screen. You can confirm that the entered details are accurate before submitting for approval.

5 Bill Payment
5.4 Create Standing Instruction 
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Complete

Once confirmed, click PROCEED TO SUBMIT. A confirmation message should be prompted.

5 Bill Payment
5.4 Create Standing Instruction 
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For Baiduri b.Digital Business, there are 2 types of user access; Initiator and Approver.

Payments are submitted by the initiator, then an approver can approve, reject and make
amendments to the request.

From the menu, go to Bill Payment → Manage Workflow.

To view a video tutorial on approving transactions, click here.

5 Bill Payment
5.5.1 Approval Workflow for Bill Payments

https://www.youtube.com/watch?v=6V47d_c2Bmc
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Step 1

Step 2

From the Filter Transactions drop down list, select either Bill Payment or Bill payment SI.

Bill Payment – records related to bill payments will be displayed.
 
Click ‘Search’ to search for specific bill payments.
You may also view a more detailed record of the transaction by clicking the reference number.

5 Bill Payment
5.5.1 Approval Workflow for Bill Payments

Step 3

Under the Action column, click on the drop-down arrow. The sub-menu containing Approve, 
Reject and Amendment will be displayed.
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5 Bill Payment
5.5.2 Approving Bill Payments

Step 4

Under the Action column, click the drop-down arrow.
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Step 5

Click Approve. The Approve Payment screen will be displayed. Here you can verify the information.

Note:

If a Bill Payment has not yet been approved after the requested date, an alert message will
be prompted to the Approver. The Approver can choose to approve or reject transaction.

5 Bill Payment
5.5.2 Approving Bill Payments
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Step 6

Step 4

Click Approve. You will be prompted with a 2FA authentication step. You will be required
to use the digital token.

On your Baiduri b.Digital Business mobile app, go to Generate Secure Code to generate the 
secure code.

Enter the generated secure code in the respective field.

Digital token

5 Bill Payment
5.5.2 Approving Bill Payments
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Step 7

Then Click Submit. A confirmation message will be prompted and the Bill Payment is considered 
approved. The approved details will be sent to the Payment List.

If a Bill Payment fails, this might be due to technical issues. In the event this happens, a Release 
Failed status will be reflected.

Click on the drop-down arrow. From here, you can choose to resubmit the approval or
cancel the release.

Note:
If a Bill Payment has not yet been approved after the requested date, an alert message will be prompted to the Approver. 
The Approver can choose to approve or reject the transaction.

Figure 4: Manage Workflow screen

5 Bill Payment
5.5.2 Approving Bill Payments
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Step 1

To amend or cancel a transaction, select either Amendment or Reject in the Manage 
workflow screen.

The Send to Amendment or Rejection screen will be displayed. 

5 Bill Payment
5.5.3 Amending and Rejecting Bill Payments
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Step 3

To confirm, click the AMENDMENT or REJECT button. A confirmation message will be prompted 
once the request should be submitted to the approver for approval.

Step 2

Under the Reason for Amendment or Reason for Rejection section, fill in the Remarks field.

5 Bill Payment
5.5.3 Amending and Rejecting Bill Payments
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5.6 Search and View Bill Payment

5 Bill Payment
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5.6.1 Search - Pending Repair (Amendment)
	 Bill Payment Records

5 Bill Payment

From the menu, go to Bill Payment → Manage Workflow. The Manage Workflow screen should
be displayed.

If you want to retrieve a specific transaction under Bill Payments, you can search by entering
the Bill Payment Reference, Pay From, Pay To, Currency, Payment Amount or Status in the 
respective fields.
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For Bill Payment SI, you can use the search field to extract a specific transaction by entering
the SI Reference, SI Nick Name, Pay From, Pay To, Frequency, Payment Currency, Payment 
Amount or Status.

Click the Bill Payment Reference hyperlink to view more details of that specific transaction.

5.6.1 Search - Pending Repair (Amendment)
	 Bill Payment Records

5 Bill Payment
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Once the Payment is approved, the details will be displayed under Payment List.

From the menu, go to Bill Payment → Payment List. The Payment List screen will be displayed.

Here, you can view the status of each transaction. From the drop-down list at the top of the page,
you can filter the transactions by Bill Payment or Bill Payment SI.

5.6.1 Search - Active (Approved) Bill
	 Payment Records

5 Bill Payment
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You will be able to view all approved payments in a list. You can also search a specific payment
by entering the Bill Payment Reference, Biller Name, Biller Code, Company, Debit Account,
Payment Currency, Biller Category or Payment Date in their respective fields.

Under the Filter Transaction drop-down list, select Bill Payment SI. The Payment List should 
display all relevant standing instructions as shown below.

To retrieve a specific transaction, enter one of the following in their respective fields, SI Reference, 
SI Nick Name, Pay From, Pay To, Frequency, Payment Currency, Payment Amount or Status.

5.6.1 Search - Active (Approved) Bill
	 Payment Records

5 Bill Payment
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In this illustration, the Biller Category and Payment Date are entered.

Click Search. The filtered transactions are displayed.

5.6.1 Search - Active (Approved) Bill
	 Payment Records

5 Bill Payment
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Click the Bill Payment Reference hyperlink to view more details of that specific transaction.

5.6.1 Search - Active (Approved) Bill
	 Payment Records

5 Bill Payment
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5 Bill Payment

To edit a Bill Payment with Pending Repair status that was sent back by the approver, the initiator
needs to edit the payment under Manage Workflow.

Under the Action column, click the drop-down arrow, a sub-menu containing Edit or Delete will
be displayed.

Figure 7: Manage Workflow screen

5.7 Edit -  Pending Repair Bill Payment Records
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Click Edit. The Edit Payment screen should be displayed. A Reason for Send to Repair notice
will be displayed. Here, you may make the necessary edits.

Past Dated Payment - Edit

Past dated payments cannot 
be edited. You will be prompted 
with the following message if an 
attempt is made.

5 Bill Payment
5.7 Edit -  Pending Repair Bill Payment Records
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Click Continue. The review screen will be displayed. Here you can review if the information
is accurate.

5 Bill Payment
5.7 Edit -  Pending Repair Bill Payment Records
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Click PROCEED TO SUBMIT. A confirmation message will be prompted and the edited transaction
will be submitted for approval.

5 Bill Payment
5.7 Edit -  Pending Repair Bill Payment Records
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5 Bill Payment

An Initiator user profile can copy a template which can be used for the same biller, but different
payment amount.

From the menu, go to Bill Payment → Payment List. The Payment List screen should be displayed.

Under the Action column, click the drop-down arrow. The sub-menu containing Copy should be
displayed.

5.8 Copy - Active (approved) Bill Payment Records
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5.8 Copy - Active (approved) Bill Payment Records

Click Copy. The Copy Payment screen should be displayed. Here, you can copy details such as
Applicant and Biller Information from selected Bill Payment records. The Payment Details needs
to be entered.

5 Bill Payment
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5 Bill Payment

Once details are entered, click CONTINUE. The review screen will be displayed. Here, you can
confirm if the details entered are accurate.

5.8 Copy - Active (approved) Bill Payment Records
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5.8 Copy - Active (approved) Bill Payment Records

Click PROCEED TO SUBMIT. A confirmation message will be prompted and the request will be
submitted for approval.

5 Bill Payment

Delete- Pending Repair (Amendment) Bill Payment Records

Under the Action column, click the drop-down arrow. The sub-menu containing Edit and Delete
will be displayed.
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5 Bill Payment

Under the Action column, click the drop-down arrow. The sub-menu containing Edit and Delete
will be displayed.

5.9.1 Delete - Pending Repair (Amendements)
        Bill Payment Records
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Step 2

Step 1

Click Delete. The review screen should be displayed.

Click Delete. The review screen should be displayed.

5 Bill Payment
5.9.1 Delete - Pending Repair (Amendements)
        Bill Payment Records
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Step 3

Step 4

Step 5

Click the DELETE button. A message will be prompted to ensure that your request is
confirmed.

Click Yes. A confirmation message will be prompted.

Click OK to close the window.

5 Bill Payment
5.9.1 Delete - Pending Repair (Amendements)
        Bill Payment Records
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6 Beneficiary Management
6.1 Create Beneficiary

Under the left panel menu, go to  Beneficiary Management → Create Beneficiary.

The Create Beneficiary screen should then appear on the right side of the screen. Fill in the 

necessary details.
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6 Beneficiary Management
6.1 Create Beneficiary

The Beneficiary list section is where you can view all the created beneficiaries so that you can 

transfer funds to them. See below on how to create a beneficiary.
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6 Beneficiary Management
6.1 Create Beneficiary
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6 Beneficiary Management
6.1 Create Beneficiary

Beneficiary Contact Details
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6 Beneficiary Management
6.1 Create Beneficiary

Beneficiary Additional Details

Beneficiary Bank Information
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6 Beneficiary Management
6.1 Create Beneficiary

The overall Review screen should be displayed after clicking CONTINUE.

Here you can verify the overall details that you’ve previously inputted before clicking PROCEED TO 
SUBMIT. Otherwise, you can click BACK to make amendments or CANCEL.
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6 Beneficiary Management
6.1 Create Beneficiary

After clicking PROCEED TO SUBMIT, a Confirmation Message will be prompted on the screen. At 
this point, your entry is complete. From here, you can click ADD ANOTHER BENEFICIARY to create 
another beneficiary.
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6 Beneficiary Management

From the menu, go to Beneficiary Management → Beneficiary List. 

Under the Beneficiary List section, these functions are available.

6.2 Edit & Delete Beneficiary
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6 Beneficiary Management
6.2 Edit & Delete Beneficiary

Figure 20 – Beneficiary List screen

Edit a beneficiary 

Under the Action column, click the drop-down arrow to show Edit and Delete function.
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Click Edit. You should see the Edit Beneficiary screen. Here, you can edit details including 
Beneficiary Nick Name, Beneficiary Contact Details and Beneficiary Additional Details.

6 Beneficiary Management
6.2 Edit & Delete Beneficiary
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Once you’ve made the amendments and edits, click CONTINUE. You should then see the Review 
screen. If all details are correct, click PROCEED TO SUBMIT.

6 Beneficiary Management
6.2 Edit & Delete Beneficiary

Figure 22 – Edit Beneficiary screen
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The Beneficiary’s details should be updated and a confirmation message is prompted.

6 Beneficiary Management
6.2 Edit & Delete Beneficiary
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6 Beneficiary Management
6.2 Edit & Delete Beneficiary

Delete a beneficiary

Under the Action column, click the drop-down arrow to show Edit and Delete function.

Click Delete. You should see the Delete Beneficiary screen where you can review their overall 
information.
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Click the DELETE button. You should be prompted with a confirmation message.
Click YES if you wish to proceed to delete the record.
 
The application displays the confirmation message as shown below.

6 Beneficiary Management
6.2 Edit & Delete Beneficiary

A confirmation message will be prompted.
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Search and View - Active Beneficiary Records

From the menu, go to Beneficiary Management → Beneficiary List. You should see the

Beneficiary List screen and view the list of Beneficiaries and their status.

6 Beneficiary Management
6.3 Search and View Beneficiary

Functions available under the Beneficiary List screen.
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6 Beneficiary Management
6.3 Search and View Beneficiary

Click on an individual Beneficiary Reference hyperlink to view more information. You should be 

lead to a page with more information.

Figure 22 – Edit Beneficiary screen
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7 Bill Payee Management 

This service allows you to pay various types of bills, including:

•	 Baiduri Bank credit cards
•	 Baiduri Finance Hire Purchase
•	 Utility bills (water and electricity)
•	 Phone bills (DST, Imagine and Progresif)

You will only be allowed to view the beneficiaries that you have created under
your own unique ID.

7.1 Bill Payment Service 
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7 Bill Payee Management 
7.2 Create Bill Payee

From the menu, go to Bill Payee Management → Create Bill Payee.

A unique Payee Reference will automatically be generated during this process.

Create Bill Payee Screen

*
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7 Bill Payee Management 
7.2 Create Bill Payee

Bill Payee Information

For an explanation of the Bill Payee Information fields, refer to the table below:
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7 Bill Payee Management 
7.2 Create Bill Payee

Biller Category: Credit Cards

To create a Bill Payee for credit card, you must fill in the relevant fields and enter the 16-digit
credit card number under the Card Number field. Then click CONTINUE

Create Bill Payee Screen
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Review

The inputted details will appear in the Review screen.

7 Bill Payee Management 
7.2 Create Bill Payee

On the Review screen, only the first and last 4-digits of the credit card number will be
displayed, the remaining numbers will be masked. If all information is correct, click
PROCEED TO SUBMIT.

The Bill Payee will be sent for approval after the credit card number has been successfully
validated by the system.

Create Bill Payee review screen

Create Bill Payee Information screen
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7 Bill Payee Management 
7.2 Create Bill Payee

Under the Review screen, you can perform these functions:

Complete

Click the PROCEED TO SUBMIT button to submit the request. The confirmation message will be
prompted on the screen.

Submit Success screen
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7 Bill Payee Management 
7.3.1 Edit - Bill Payee Records

The Bill Payee records under the Payee List can be edited.

Under the menu, go to Beneficiary Management → Payee List.
You should then see a Payee List screen.
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7 Bill Payee Management 

Under the Action column, click the drop-down arrow to show Edit and Delete

Payee List Screen

Step 1

7.3.1 Edit - Bill Payee Records
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Click Edit. You should see the Bill Payee Information screen where you will only be
able to edit the Account Number field.

Edit Payee Screen

Step 2

7 Bill Payee Management 
7.3.1 Edit - Bill Payee Records
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After making the amendments, click CONTINUE, you should see the Review screen. If
all information that you have updated or modified is correct, click PROCEED TO SUBMIT.

The confirmation message will be prompted on the screen.

Edit Payee Screen

Edit Payee Screen

Step 3

Step 4

7 Bill Payee Management 
7.3.1 Edit - Bill Payee Records
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A confirmation message will pop up on the screen.

Delete Confirmation message

Delete - Bill Payee Records

Under the Action column, click the drop-down arrow to show Edit and Delete function.
Click Delete if you wish to delete the record.

You should be lead to the Delete Payee screen. Click DELETE at the bottom of the screen.

7 Bill Payee Management 
7.3.2 Delete - Bill Payee Records
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Deletion Status Message

7 Bill Payee Management 
7.3.2 Delete - Bill Payee Records
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Payee List screen

7 Bill Payee Management 
7.4 Search & View Bill Payee

Once a new Bill Payee has been created, it will appear under Payee List.

Under the menu, go to Bill Payee Management → Payee List. You should view the

Payee List page where you can view the full list of payees and their corresponding status.
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You can perform the following functions under the Payee List screen.

Under Bill Payee records, if you wish to view a specific record, you can search for it by inputting
the respective Payee Reference, Payee Nick Name, Biller Category, Biller Name or Biller Code.

Payee List screen

7 Bill Payee Management 
7.4 Search & View Bill Payee

Enter the required details under Payee Reference and Biller Payee Nick Name. Then click Search.

Step 1
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7 Bill Payee Management 
7.4 Search & View Bill Payee

Payee List screen

View Bill Payee

You should be able to view the requested details under Payee List.

Step 2

To view more information, click the Payee Reference hyperlink.

You should then be able to view more information as shown below.

Step  3

Step  4
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8 Payroll
8.1 Payroll Overview

With the Payroll feature, you can pay your employees’ salaries easily and securely.

In a single transaction, you can pay the salaries of multiple employees with accounts within 
Baiduri Bank or at other local banks.

To view a video tutorial on how to manage payroll, click here.

https://youtu.be/ES7Vt8myqMs
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iFILE is another available format which is typically generated from a Company’s HR Payroll
system. See sample below:

8 Payroll
8.2 Preparing Your Payroll

You can upload the payroll file using iFILE or CSV formats. You will need to prepare the payroll 
details in the same format as the sample payroll file, which can be downloaded when you create 
the payroll. Save the payroll file as an Excel Spreadsheet in CSV format only.

Sample of Payroll File

Important:

*In the excel spreadsheets, ensure account numbers are inputted in full with leading zeros.
Include an apostrophe at the beginning of the account number, for example ‘0100100123456

*Ensure employee names inputted fully match their names with their bank account. This will help to avoid the system 
rejecting transactions. Please make sure that employee names do not exceed 35 characters.

Sample of payroll file - Notepad

Sample of payroll file
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8 Payroll
8.3 Create Payroll

From the menu, go to Payroll → Create Payroll. The Create Payroll screen should be displayed.

Payroll details

Download the sample file in the chosen format.

Enter the file name. This is a summary of the payroll details for the 
customer's reference only.

Upload your Payroll File
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Payroll Header fields

8 Payroll
8.3 Create Payroll
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Once all details are entered, the following screen will appear.

8 Payroll
8.3 Create Payroll
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8 Payroll
8.3 Create Payroll

Review the Payroll Details

Click the CONTINUE button. The request will be reflected on the Review screen. The number of
transfers to be made within Baiduri Bank and other local banks will be indicated after verified by
the system. Rejected records will also be indicated here.
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8 Payroll
8.3 Create Payroll

Complete

Click PROCEED TO SUBMIT. A confirmation message will be prompted.

• The payroll file will then be sent to the View Upload File.

• The uploaded file details can be viewed in View Upload File by the Maker and the Approver.

• The uploaded file is subjected to the Batch job process.
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8 Payroll
8.3.1 View Upload File

View Upload File

Once the payroll file is uploaded and submitted, the details can be viewed under View Upload
File in the menu. Here, maker can view the status of the payroll file, whether they are pending
approval, being processed or failed.

From the menu, go to Payroll → View Upload File. The View Upload File screen should be displayed.

User can also view rejected payrolls error statuses under View Upload File → Record Details  
→ Rejected Records Summary
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8 Payroll
8.3.1 View Upload File

View upload file fields
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Enter all or any one of the above fields, then click the SEARCH button, the search results should
be displayed on the screen.

The payroll file sent for the verification process can be viewed here. The request will be moved to the Approval Workflow 
for the Approver to review after 5 to 10 minutes.

8 Payroll
8.3.1 View Upload File
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8 Payroll
8.4.1 Approve Payroll

All records under Manage Workflow will have Pending Approval status. Once they have been
approved, their status will be changed to Fully Approved.

From the menu, go to Payroll → Manage Workflow. The View Upload File screen should
be displayed.

Status

• Pending Approval: When payments are prepared by the Maker and submitted for approval

• Fully Approved: When the Approver approves the upload. The records will be pending to be released.
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8 Payroll
8.4.1 Approve Payroll

Manage Workflow functions
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Under the Action column, click the drop-down arrow, the sub-menu containing Approve and
Reject should be displayed.

Click Approve. The Approve Payroll screen should be displayed. Here, you can verify information
that was inputted.

A notice about the processing status will be prompted. Click X to proceed with approvals.

8 Payroll
8.4.1 Approve Payroll
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Click the Approve button. The 2FA authentication screen should be displayed. Here is where the
approval process step is done. Enter the OTP generated via digital token.

Click SUBMIT. A confirmation message should be prompted and the payroll is approved.

8 Payroll
8.4.1 Approve Payroll

Digital token
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From the menu, go to Payroll → Manage Workflow. The View Upload File screen should
be displayed.

Under the Action column, click the drop-down arrow, the sub-menu containing Approve and
Reject should be displayed.

Click REJECT. The Reject Payroll screen will be displayed. Enter notes or reasons regarding the
reason for rejecting the payroll in the Remarks field.

Click the REJECT button. 2FA is required to complete the process.

8 Payroll
8.4.2 Reject (Payroll)
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8 Payroll
8.5 Payroll List

This section contains all statuses of transactions after the payroll file has been approved by the 
Approver. This includes records that have been successfully approved and processed, records that 
have failed, records that are set to be processed on a future date, and records that are currently 
being processed.

There are two types of payrolls under Payroll List:

Before Batching
All payrolls under this page are auto-validated and prepared for processing. If payroll file fails, the 
Maker will need to re-submit a new payroll.
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8 Payroll
8.5 Payroll List

After Batching
The payrolls on this page have been processed and/or is ready for transfer.

Stop Future Dated Payroll

Under the After Batching payroll type, an Approver can stop a Future Dated Payroll.

Definition of statuses under After Batching Type:-

• Success – Payroll has been transferred successfully

• Stopped – Payroll was stopped

• Future Dated – Payroll is ready for processing on the specified payment date

• Pending Processing – Payroll is pending to be processed by the Bank

• Processed with failure/Failed – Some or all transactions failed during processing. Click on
  the Payroll Batch Reference link to view details of the successful and failed transactions



Baiduri b.Digital Business User Guide 186

8 Payroll
8.6 Payroll (USD to USD)

With the Payroll feature, you can pay your employees' salaries easily and securely. Adding a new 
transaction to the payroll feature allows you to use USD to USD internal accounts for payroll.

Preparing your Payroll

From the menu, go to Payroll → Create Payroll

The maker is required to fill in the payroll details:

• Payroll format - A dropdown menu where
  the maker can select either iFile or CSV file format.
• Upload type - Enter a description for your file 
  (alphanumeric characters only).
• Sample file - This is an optional step where the 
  maker can download a sample payroll file.
• Browse - Click this button to select the file you 
  want to upload.

You can upload your payroll data in CSV format. You will need to prepare the payroll details in the 
same format as the sample payroll file, which you can download when you create a new payroll. 
Save the payroll file as a CSV file.

Sample of Payroll File
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iFile is another available format, typically generated by a company's HR payroll system. See the 
sample file below:

Important:

Account Numbers
• Enter account numbers in full, including leading zeros. For example, enter '0100100123456' instead 
  of 100100123456.

Employee Names
• Ensure employee names entered match exactly with their bank account names. This helps avoid 
  rejected transactions.
• Please note that employee names cannot exceed 35 characters.

8 Payroll
8.6 Payroll (USD to USD)
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8 Payroll
8.6 Payroll (USD to USD)

Create Payroll

From the menu, go to Payroll → Create Payroll. The create payroll screen will appear.

Payroll details
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Payroll Header Fields

8 Payroll
8.6 Payroll (USD to USD)

Once all details are entered, 
the maker can continue to 
the review page.
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8 Payroll
8.6 Payroll (USD to USD)

Review the Payroll details

• Click the Continue button. Your request will be reflected on the Review screen.

• The following details will be displayed:

		  • Debit account
		  • Payment records
		  • Number of records
		  • Currency
		  • Total amount
		  • Fees (in BND)

• If there are no errors, click Continue to Submit to upload the file for processing.
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Click Proceed to Submit to initiate the upload process. A confirmation message will then appear.

8 Payroll
8.6 Payroll (USD to USD)

View upload file

Once you upload and submit your payroll file, you can track its status using the View Upload File 
menu option. This section allows you to see if your file is:

•	 Being processed
•	 Failed

From the menu, go to Payroll → View Upload File.  The View Upload File screen will then appear.

You can also view specific error details for rejected payrolls under View Upload File → Record → 
Rejected Records Summary.
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8 Payroll
8.6 Payroll (USD to USD)

Payroll process progress and Status:

Maker can track the progress of the payroll file using the "View Upload File" function:

Go to Payroll → View Upload File. The View Upload File screen will then appear.

Once your file is processed, you can check the final status (success or failure) in the View 
Upload List. The processing time typically takes 2-3 minutes, depending on the number of 
records in your file.

Enter any or all of the above fields in the search bar and click SEARCH to view the results on screen.

View Upload File Fields
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Failure within View Upload List: 

If the payroll upload fails to process, the status will change to Failed. The Maker can then click on 
the reference hyperlink to view the reason(s) for the failure.

8 Payroll
8.6 Payroll (USD to USD)
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8 Payroll
8.6 Payroll (USD to USD)

Payroll List

This section provides an overview of all payroll transaction statuses, both before and after the 
payroll file has been approved by the Approver. This includes records that have been:
 
•	 Successfully approved and processed
•	 Processed with errors (failed)
•	 Scheduled for future processing
•	 Currently being processed

The Payroll List displays two main types:

Before Batching
In this stage, all payrolls undergo automatic validation and are prepared for processing. If a 
payroll file fails validation, the Maker will need to resubmit a new payroll file.
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After Batching
Payrolls on this page have been processed and are now ready for transfer.

Definition of statuses under After Batching Type:

• Future dated – Payroll is scheduled for processing on the specified payment date.
• Stopped – Payroll processing was stopped.
• Sent to bank – Payroll has been sent to bank for processing. 
• Failed – Transaction failed during processing. Click the Payroll Batch reference link to view details   
  of failed transactions.

Stop Future Dated Payroll
An Approver can stop a future dated payroll under the "After Batching" category.

8 Payroll
8.6 Payroll (USD to USD)
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8 Payroll
8.6 Payroll (USD to USD)

Approve Payroll

All records under Manage Workflow will initially have a Pending Approval status. Once 
approved, the status will change to Fully Approved.

To view and manage your payroll submissions, go to Payroll and then Manage Workflow. This 
will display the View Upload File screen.

Status

• Pending Approval: This status indicates that payments have been prepared by the Maker 
  and submitted for approval.

• Fully Approved: The Approver has approved the upload. The records are now awaiting release.
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In the Action column, click the dropdown arrow to reveal a submenu with Approve and Reject 
options.

Click Approve to proceed. The Approve Payroll screen will then appear, allowing you to verify the 
entered information before finalising.

8 Payroll
8.6 Payroll (USD to USD)

Manage Workflow functions
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8 Payroll
8.6 Payroll (USD to USD)

Important note: Even if the payroll payment date has passed its due date, the Approver can 
still approve it for processing on the next working day. However, to proceed with approval, the 
user will need to close (click the X) on the past payment date notification.

Click Approve to proceed. You will then be prompted for Two-Factor Authentication (2FA) to 
verify your identity. Enter the One-Time Password (OTP) generated by your digital token.
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After reviewing the payroll details, the Approver can proceed to generate the Two-Factor 
Authentication (2FA) by using the physical token or soft token to process the transaction.

Click SUBMIT to process the transaction. A confirmation message will then be displayed indicating 
successful payroll approval.

8 Payroll
8.6 Payroll (USD to USD)
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To navigate to the payroll status

Makers and Approvers can go to Dashboard > Financial > Transaction statistics. 
Under the Filter menu, select Payroll. Then, choose the desired dates using the provided filters for 
payroll creation and payment dates. This will display the User Workflow and the Bank Workflow.

8 Payroll
8.6 Payroll (USD to USD)
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9 Bulk Payment
9.1 Bulk Payment Overview

With the bulk payment feature, you can now make multiple transfers to your local vendors by 
uploading a single file.

Note: The Bulk Payment feature is only for BND payments within Baiduri Bank and to other local 
banks.
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9 Bulk Payment
9.2 Preparing the Bulk Payment file

Click on File Upload in the menu, then select Bulk File Upload. This will open the Create Bulk 
Payment File Upload screen

• Your Reference: Enter your company reference using alphanumeric characters only.

• Upload Type: Choose either Within Bank to transfer funds within the bank or Other 	
  Bank to transfer to other local banks. 

• Payment Date: Set the date of when payments need to be made.

Important Note:

The cutoff times for bulk payment file processing are as follows:

•	 For transfers within the bank: 10:30pm
•	 For transfers to other local banks: 1:30pm (Monday to Friday)

If the set payment date falls on a future working day, your bulk payment will be processed on that 
specified date.

File Format: Select Bulk Upload CSV format.

After selecting the file format, a hyperlink to the sample file will appear. To prepare the bulk 
payment file for the first time, you can download the sample file and create the bulk upload by 
following the provided template.
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9 Bulk Payment
9.3 Creating a Bulk Transfer file

Here, you can download the sample file for either Within Bank or Other Bank, 
depending on the selected Upload Type.

After downloading and opening the sample file, you may encounter a notice 
about potential data loss. Click the X button to cancel, located on the far right. 

Note: The uploaded file will be in CSV format.
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9 Bulk Payment
9.3 Creating a Bulk Transfer file

Within Bank sample file

• Column A (Debit Account): Enter the debit account number. You may enter debit 
  account numbers that are linked within the organisation group.

• Column B (Payment Amount): Specify the payment amounts, with a minimum of 
  BND0.01 up to 2 decimal points. Only numeric characters are allowed.

• Column C (Payment Currency): The payment currency will always be in BND. Do not 
  change this column, as it may cause the file upload to fail. 

• Column D (Beneficiary Name): Provide the beneficiary’s name. The number of characters 
  allowed is up to 35 characters. Please note there should not be any spacing at the end   
  and avoid using numbers or special characters.

• Column E (Beneficiary Account): Enter the beneficiary's account number. This should only 
  be in BND.

• Column F (Payment Type): Payment type for local bank is BOOKTRF. Do not change this 
  column, as it may cause the file upload to fail.

• Column G (Narrative): Enter any additional information for your reference. This is a non 
  mandatory column.
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9 Bulk Payment
9.3 Creating a Bulk Transfer file

Other Bank sample file

• Column A (Debit Account):  Enter the debit account number. You may enter debit account 
  numbers that are linked within the organisation group.

• Column B (Payment Amount): Specify the payment amounts, with a minimum of BND0.01 up 
  to 2 decimal points. Only numeric characters are allowed.

• Column C (Payment Currency): ): The payment currency will always be in BND. Do not 
  change this column, as it may cause the file upload to fail.

• Column D (Beneficiary Name): Provide the beneficiary's name. The number of characters       
  allowed is up to 35 characters. Please note there should not be any spacing at the end and 
  avoid using numbers or special characters.

• Column E (Beneficiary Account): Enter the beneficiary bank's bank code.

• Column F (Beneficiary Account): Enter the beneficiary's account number. This should only be 
  in BND.

• Column G (Payment Type): Enter either ACH or RTGS only.

	 o	 Automated Clearing House (ACH): Recommended for payments such as 
		  sending funds to companies.

	 o	 Real-Time Gross Settlement (RTGS): Recommended for larger amount transfers 
		  and payments that need to be settled urgently.
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9 Bulk Payment
9.3 Creating a Bulk Transfer file

• Column H (Narrative): Enter any additional information for your reference. This is a 
  non-mandatory column.

• Column I (Address 1): It is mandatory to fill in the beneficiary's local address, limited to 
  70 alphanumeric characters, with no special characters.

• Column J (Address 2): Reserved in case the first address exceeds its character limit. It 
  is also limited to 70 alphanumeric characters.

After completion, save your file as CSV (Comma Delimited) format. Do not open the file 
once it has been saved.

After creating the file, you can upload it by clicking the Please select a file button. 
Please note that you can only upload one file at a time.

Once you've completed the above steps, proceed to upload by clicking Continue 
for processing.



207 Baiduri b.Digital Business User Guide

9 Bulk Payment
9.4 Review Stage

The request will appear on the Review screen, where you can review all the details before 
processing. Details such as the debit account, payment records, number of records, currency, 
and total amount will be displayed.

Failed records

020011111298345
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9 Bulk Payment
9.4 Review Stage

The record section will detail multiple errors or necessary repairs, including the reasons 
for failure. If errors are detected, the upload process will not proceed.

To proceed with the bulk transfer, you must rectify these errors. Click  the Back button 
to re-upload the repaired file.

If no errors are found, you can proceed by clicking Continue Processing. This action will 
upload the file for full processing.
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9 Bulk Payment
9.5 Progress and status

To check the progress of your file, go to Bulk Payment and select View Upload List.

Once processed, you can go to the View Upload List to check if the file is still being 
processed or if the upload has failed. The file processing typically takes about 2-3 
minutes, depending on the number of records in the file.

If the bulk upload fails to process and the status changes to Failed, you can click on 
the reference hyperlink to identify the reason(s) for the failure.

Failure within View Upload List
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9 Bulk Payment
9.5 Progress and status

The Approver will receive a notification only after the upload has been successfully 
processed. You can access the dashboard to view any failures in the bulk upload under 
financial transaction statistics.

• After successful processing, the file is removed from the 'View Upload List' and transferred to   
  the Approver's Bulk Payment management workflow.

• To check the file status, access the 'View Upload List' to see if it is still processing or if the 
  upload failed. Processing takes about 2-3 minutes.

• Once processing is completed, the file will no longer appear in the 'View Upload List' and will 
  move to the Approver's bulk file workflow.

• For files that fail to upload, click on the hyperlink associated with the reference number to 
  identify the cause of failure.
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9 Bulk Payment
9.6 Approving the Bulk Payment (For Approver)

To approve, you should access Bulk Payment and select Manage Workflow.

Once a bulk payment file is submitted, you can then review it under the bulk file workflow. 
Here, you can see a list of bulk payment files that have been uploaded and can download 
them for review. 

To authorise, go to the action drop-down list and select Authorise.

You will need to review the details of the bulk payment before clicking Approve or Reject.
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9 Bulk Payment
9.6 Approving the Bulk Payment (For Approver)

After reviewing, proceed to generate the soft token or use a physical token to process 
the transaction.
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9 Bulk Payment
9.7 Viewing Bulk File list

To view the Bulk File Payment list, you can check under Bulk Payment, then Bulk File List. 
Both you (the maker) and the Approver can view the approved transactions within the Bulk 
File list. The list may display four different statuses:
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9 Bulk Payment
9.7 Viewing Bulk File list

1.	 Pending Processing

2.	 Proceed With Failure

3.	 Success

4.	 Failure

Each status has a hyperlink reference to view the status of each transaction individually. 
Additionally, all statuses are displayed in the dashboard.
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10 Reports and Advices
10.1 Reports and Advices Overview

Download reports and advices for your own reference, including the following:

Account Balance Report

Transaction History Report

Advice
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10 Reports and Advices
10.2 Account Balance Report

From the menu, go to Reports →Account Balance Report. The Account Balance Report screen 
should be displayed.
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10 Reports and Advices
10.2.1 Searching Account Balance Report
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10 Reports and Advices
10.2.1 Searching Account Balance Report

Click the RUN REPORT button. The Account Balances Report screen should be displayed.

To download the report, select the format of the report (PDF or CSV).

Reports can also be downloaded in PDF format.

Download report as a PDF File



219 Baiduri b.Digital Business User Guide

Download report as a CSV file

Reports can also be downloaded in CSV format. This allows you to easily import the data into the 
company’s accounting software or spreadsheets.

10 Reports and Advices
10.2.1 Searching Account Balance Report
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Transaction History Report

You can also download the transaction history report of a specific account on a specific period. 
From the menu, go to Reports → Transaction History. The Transaction History Report screen should 
be displayed.

10 Reports and Advices
10.2.1 Searching Account Balance Report
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Click the RUN REPORT button. The Transaction History Report screen should be displayed.

10 Reports and Advices
10.2.1 Searching Account Balance Report
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To download the report, select the format of the report (PDF or CSV).

Download Transaction History report as a PDF File

Reports can also be downloaded in PDF format.

10 Reports and Advices
10.2.1 Searching Account Balance Report
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Download Transaction History report as CSV Format

10 Reports and Advices
10.2.1 Searching Account Balance Report
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10.3 Advices

Download debit advices for transactions made for Telegraphic Transfers.

From the menu, go to Reports → Advices. The Advices screen should be displayed.

10 Reports and Advices
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Click the SEARCH button. The Advices screen should be displayed.

10 Reports and Advices
10.3 Advices
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Select the advice you wish to download and click the DOWNLOAD button.
The document will be downloaded in PDF format.

10.3 Advices

10 Reports and Advices



227 Baiduri b.Digital Business User Guide

11 Account Sweeps
11.1 Account Sweeps Overview

This feature allows you to schedule automatic 
transfers between your company’s accounts when 
the account balance reaches a specified amount, 
according to the rule type that you’ve set. You also 
have the flexibility to schedule account sweeps at 
specific times, including weekends. You can also view 
transactions by generating the report under Account 
Balance Report.
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11 Account Sweeps
11.2 Create Account Sweeps

From the menu, go to Account Sweeps → Create Sweep.
The Create Sweep screen should be displayed.

Sweep Request features

Fields

Mandatory

Mandatory

Mandatory

Mandatory

Mandatory

Mandatory

Optional

Description Mandatory/Optional

Select the Company name from the drop-down list

Select your company account that you wish to transfer funds from

Select your company account that you wish to transfer funds to

Choose between 2 options:

• Minimum Balance Sweep: sweeps the entire amount
excluding the minimum balance amount required to be 
maintained in the account. 

• Fixed Amount Sweep: set a fixed amount to sweep
to the sweep account.

Set the desired date of sweep. The current day date will be 
populated by default.

Set a date of when you want the Account Sweep function to stop

Enter any remarks or notes that is important to know regarding 
these transactions

Choose Company

Sweep From

Sweep To

Sweep Type

Effective Date

Expiry Date

Remarks

Note:
The transactions are through service desk and may incur some delays in payment settlements.
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12 Trade Applications
12.1 Trade Overview

In this section, you can submit trade online applications easily, including:

Shipping Guarantee / Irrevocable Letter of Credit / Letter of Credit Amendment
/ Acceptance of Discrepancy / Bank Guarantee
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12 Trade Applications
12.2 Shipping Guarantee

Typically, as an importer, you would have to visit the bank to submit a request for shipping 
guarantee for the shipping company to obtain your imported goods. Shipping guarantees are 
raised to indemnify the bank against all consequences and liabilities.

From the menu, go to Trade → Shipping Guarantee.
The Create Shipping Guarantee screen should be displayed.
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12.2 Shipping Guarantee

Shipping Guarantee Main Information fields

Under Terms and conditions section, enter the Commission charges in percentage.
Then click on the tick box.

Click CONTINUE. A Review screen should be displayed. Once you have verified the information, 
click PROCEED TO SUBMIT to process the request. A confirmation message should be prompted 
and the details is submitted for approval.

The form can also be saved as a draft which can be viewed and edited under Manage Workflow.

Fields

Reference LC No

Relating to shipment per

Choose Company

Date

Particulars

The value of the 
merchandise per 
Invoice attached as

Beneficiary Name

For all other charges 
please debit our 
account no.

Enter your LC reference number Mandatory

Mandatory

Mandatory

Mandatory

Mandatory

Mandatory

Mandatory

Mandatory

Enter details about the imported goods

From the drop-down list, select the respective company

Set the current date

Enter the LC particulars 

Enter the total invoice amount of the imported goods

Enter the Shipping Company name that you 
have acquired

Choose the company account you would like to debit 
from for any charges incurred

Description Mandatory/Optional

12 Trade Applications
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12.3 Irrevocable Letter of Credit

Application Details

From the menu, go to Trade → Irrevocable Letter of Credit.
The Create Irrevocable Letter of Credit screen should be displayed.

Fields

Your Reference

Advising Bank

Applicant Name

Contact Person Name

Address (Line 2)

Telephone Number

Fax Number

Country

Address

Enter a reference so that you can identify the 
transaction in future

Optional

Mandatory

Mandatory

Mandatory

Mandatory

Optional

Mandatory

This field is for Bank Use only  

Enter the applicant’s name 

Enter the designated contact person’s name 

Enter the applicant’s address

Additional lines for the applicant’s address

Enter the applicant’s telephone number 

Enter the applicant’s fax number or email address

From the drop-down list, select the 
applicant’s country

Description Mandatory/Optional

Optional

Optional

12 Trade Applications
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12.3 Irrevocable Letter of Credit

Beneficiary Details

Fields

Beneficiary Name

Beneficiary
Advising Bank

Address

Address (Line 2)

Country

Enter the name of the beneficiary

Enter the beneficiary’s address

Enter the beneficiary’s name

Select the beneficiary’s country

Mandatory

Mandatory

Non-Mandatory

Mandatory

MandatoryBased on the country selected, the 
Beneficiary Advising Bank can be 
chosen. Select Others if the correct 
option is not listed.
If you’ve selected Others, you will need 
to provide the following:
a) Beneficiary Bank Name
b) SWIFT Code
c) Beneficiary Bank Address

Description Mandatory/Non-Mandatory
/Auto-populate

12 Trade Applications
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12.3 Irrevocable Letter of Credit

LC Details

Fields

Beneficiary Name

Amount

Number of Days

Expiry Date

Confirmation of the Credit

Partial Shipment

Transhipment

Insurance to be covered 
by applicant

Credit Available With

From the drop-down list, select the respective currency

Enter the Amount 

Enter the Days

Set the Expiry Date

There are 2 options, select either Request 
or Not Requested.

There are 2 options, select either Allowed 
or Not Allowed.

There are 2 options, select either Allowed 
or Not Allowed.

There are 2 options, select Yes or No

From the drop-down list, select Deferred, 
Acceptance or By Payment at Sight

Mandatory

Mandatory

Mandatory

Mandatory

Mandatory

Mandatory

Mandatory

Mandatory

Mandatory

Description Mandatory/Optional

12 Trade Applications
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12.3 Irrevocable Letter of Credit

Shipment and Goods Details

Fields

From

To

Terms

Goods

Not later than

Enter the Sender’s details 

From the drop-down list, select 
CIF, C&F, FOB or Others

Enter details about the goods

Set the date

Mandatory

Mandatory

Optional

Mandatory

MandatoryEnter the Recipient’s details 

Description Mandatory/Optional

12 Trade Applications
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12.3 Irrevocable Letter of Credit

Click NEXT. The Transport Documents section will be displayed. 

Fields

Signed commercial invoices in Enter the 
number of 
copies

From the 
option, 
select the 
required 
Transport 
Document.

From the 
Transport 
Document, 
select the 
required 
option

Optional

Optional

Mandatory

Description Mandatory/Optional

12 Trade Applications
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12.3 Irrevocable Letter of Credit

Insurance Documents fields

Fields

From the Insurance 
option, select either 
Policy or Certificate for 
110 percent of invoice 
value covering the 
following risks.

Select Certificate of 
Origin Declaration of 
Origin, if applicable

Optional

Optional

Description Mandatory/Optional

12 Trade Applications
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12.3 Irrevocable Letter of Credit

Fields

User can specify other 
related information in 
the respective field

Enter the number of 
Packing List 

Enter the number of 
Weight List 

Enter the number of 
Signed Delivery Order 

Enter other details in 
the respective field

Enter the number 
of days in the 
respective field

Packing List Copies

Weight List Copies

Signed Delivery Order in Copies

Others

Optional

Optional

Optional

Optional

Optional

Optional

Description Mandatory/Optional

12 Trade Applications
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12.3 Irrevocable Letter of Credit

Terms & Conditions

Click NEXT. A review screen will be displayed where you can review the inputted details.
Once verified, click PROCEED TO SUBMIT. A confirmation message should be prompted and 
the details is submitted for approval.

The form can also be saved as a draft and be viewed and edited under Manage Workflow.

Fields

Choose Company

For all other charges please debit our 
account no.

Special Instruction

In consideration of your agreeing to open this credit 
on the Terms and Conditions stated at my/our.....

There are 2 
options, select 
Beneficiary or 
Applicant of 
who should 
bear charges

From the 
drop down 
list, select the 
Company

Select the 
account that 
you would 
like to debit 
charges from

Enter any 
special 
remarks, if any

Tick the 
checkbox

Mandatory

Mandatory

Mandatory

Mandatory

Optional

Description Mandatory/Optional

12 Trade Applications
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12.4 Letter of Credit Amendment

From the menu, go to Trade → Letter of Credit Amendment.
The Create Letter of Credit Amendment screen should be displayed.

Letter of Credit details

Fields

Enter your LC reference number

From the drop-down list, select the required Currency 

Enter the Amount 

The LC should be taken in the favour of seller

Set the Date of the application

Currency

LC Reference

Amount

In Favour of

Date

Mandatory

Mandatory

Mandatory

Mandatory

Mandatory

Description Mandatory/Optional

12 Trade Applications
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12.4 Letter of Credit Amendment

Amendment details

Select either either Amount Increased or Amount Reduced to proceed.

Fields

Set the extended shipping date

Select the expiry date

If the LC amount increased, then specify the 
amount and total amount in the respective fields

If the LC amount decreased, then specify the 
amount and total amount in the respective fields

Enter other remarks, if any.

If you prefer charges to be absorbed by the 
Beneficiary, specify the instruction in this field.  

Expiry Date Extended to

Shipping Date Extended to

Amount Increased By 
& Making Total of

Amount Decreased By 
& Making Total of

Others/Remarks

Optional

Optional

Optional

Mandatory 
depending on 
the amendment 
specified

Mandatory 
depending on 
the amendment 
specified

Description Mandatory/Optional

12 Trade Applications
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12.4 Letter of Credit Amendment

Click NEXT. A review screen will be displayed where you can review the inputted details.
Once verified, click PROCEED TO SUBMIT. A confirmation message will be prompted and the 
details are submitted for approval.

The form can also be saved as a draft and be viewed and edited under Manage Workflow.

Declaration details

Fields

From the drop-down list, select Company Name

Select the account you would like to debit from

Enter your address

Additional space to enter your address

Enter the country code and telephone number 
in the respective fields

Debit From

Choose Company

Address

Address (Line 2)

Telephone

Optional

Mandatory

Mandatory

Mandatory

Mandatory

Description Mandatory/Optional

12 Trade Applications
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12.5 Acceptance of Discrepancy

From the menu, go to Trade → Acceptance of Discrepancy.
The Create Acceptance of Discrepancy screen should be displayed.

LC Information

Fields

Enter the Letter of Credit No.

From the drop-down list, select the company.

Select the account you would like to 
debit charges from

Select the required Currency

Enter the Amount

Enter the In Favour of details

Set the Date

Choose Company

Letter of Credit No

Currency

Amount

In Favour of

Date

Mandatory

Mandatory

Mandatory

Mandatory

Mandatory

Mandatory

Mandatory

Description Mandatory/Optional

12 Trade Applications
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12.5 Acceptance of Discrepancy

Declaration details

You will need to select at least one discrepancy in order to proceed with this step.

Click NEXT. A review screen will be displayed where you can review the inputted details.
Once verified, click PROCEED TO SUBMIT. A confirmation message will be prompted and the 
details are submitted for approval.

The form can also be saved as a draft and be viewed and edited under Manage Workflow.

Fields

Tick the check box, set the date 

Tick the check box, set the date

Tick the check box and enter any other remarks

per fax dated

per documents scheduled dated

Others

Description

12 Trade Applications
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12.6 Bank Guarantee

From the menu, go to Trade → Bank Guarantee. 
The Create Bank Guarantee screen should be displayed.

Fields

Your Reference

Application Type

Choose Company

Enter a reference that can remind you of the 
transaction or request

From the drop-down list, select the Company

Mandatory

Mandatory

MandatoryThere are 2 options, select New or Renewal

Description Mandatory/Optional
/Auto-populate

Bank Guarantee details

12 Trade Applications
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12.6 Bank Guarantee

Click CONTINUE. A review screen will be displayed where you can review the inputted details. 
Once verified, click PROCEED TO SUBMIT. A confirmation message will be prompted and the 
details is submitted for approval.

The form can also be saved as a draft and be viewed and edited under Manage Workflow.

Fields

Guarantee Type

Beneficiary Name

Currency

Amount

Validity Date

Purpose

Third party Applicant

Select the account that you 
wish to debit charges from

From the drop-down list, select 
one of the following:
- Labour Guarantee
- Performance Bonds
- Custom Guarantee
- Other Guarantee
- BID Bond
- Retention Bond
- Advance Payment Guarantee

Enter the Beneficiary Name

The currency is auto-populated 
based on the Debit Account 
selected 

Enter the Amount 

Set the date of validity

Enter the purpose of the 
Bank Guarantee 

There are 2 options, 
select Yes or No

Mandatory

Mandatory

Mandatory

Mandatory

Mandatory

Mandatory

Mandatory

Auto-populate

Description Mandatory/Optional
/Auto-populate

12 Trade Applications
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12.7 Approval Workflow (For approvers)

From the menu, go to Trade → Manage Workflow.
The Manage Workflow screen will be displayed.

Under the Action column, click the drop-down arrow.
The sub-menu containing Approve, Reject and Amendment should be displayed. 

Action

Approve

Reject

Amendment

When the Maker clicks Approve, the transaction will be marked as approved.
If the transaction fails due to a system error, the transaction will be marked as 
Release Failed. You will then need to resubmit the transaction.

The Approver can send a transaction back to the Maker to make an Amendment. 
A reason must be entered in the Remarks field.

The Maker can choose to click Reject if there are discrepancies in the 
transaction entry. A reason for the rejection will need to be inputted in 
the Remarks field.

Description

12 Trade Applications
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12.8 Edit/Save As Draft/Delete

Under Manage Workflow, you can do the following for trade applications:

Edit transactions 
sent back by the 
Approver

Save a draft of 
the application

Delete a record

12 Trade Applications
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Overview
This section allows you to stop any future dated transfers, bill payments and standing instructions. 
Only requests with 24 hours or more lead time can be stopped.

Stop Payment Instruction
From the menu, go to Stop Request → Stop Payment Instruction. 
The Stop Payment Instructions screen should be displayed.

Under the Payment Type field, there are 2 options, Single Payment and Batch Payment.

13 Stop Requests
13.1 Stop Payment Instruction
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13 Stop Requests
13.1 Stop Payment Instruction

Under Manage List, click on one of the Payment Reference.
Under the Action column, click the drop-down arrow.
A sub-menu containing Stop Payment is displayed.

You are required to enter the reason for stopping the transaction in the 
Remarks field. Click Stop Payment and the request will be sent for approval.
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12.2 Approval Flow (Payment)

From the menu, go to Stop Request → Manage Workflow.
The Manage Workflow screen should be displayed.

Under the Payment Type field, there are 2 options, Single Payment, and Batch Payment.

Figure 15: Manage Workflow screen

13 Stop Requests
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12.2 Approval Flow (Payment)

Under Workflow List, click on one of the Payment Reference.
Under the Action column, click the drop-down arrow.
A sub-menu containing Approve and Reject is displayed.

Actions

Approve

Reject

Approve the Stop Request

Reject the Stop Request

Response

13 Stop Requests
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14 Cheque Book Request
14.1 Cheque Book Request

You can request for new cheque books online and specify 
your preferred branch of where you would like to collect.

From the menu, go to Service Request → Cheque Book.
The Cheque Book Request screen should be displayed.

The cut-off time for cheque books requests is 11.00am. Requests that are made after the 
cut-off time, Sundays or public holidays will be processed the next working day.

Charges apply. Refer to Bank Tariffs for details.
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15 Tools
15.1 FX Rates

In this section, you can view Foreign Exchange currency rates for telegraphic transfer 
and overdraft services, including:
•  Buying rate
•  Selling rate
•  Buying overdraft

FX Rates
From the menu, go to Tools → FX Rates. The FX Rates screen should be displayed.

01235 xyz company
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16 User Admin
16.1 User Admin Overview

User Admin Overview
User Admin allows the admin user to suspend users and maintain limits for each user. Only user 
with admin rights can the access of the corporate admin module. 

User Access
Admin - User
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16 User Admin
16.2 Limit Management

From the sidebar, navigate to Corporate Admin 
and click the drop-down arrow to view the 
options as highlighted on the right side. 

Click Limit Management. The Limit Management window is displayed. Corporate Admin may select 
the user they wish to change the transaction limits. 
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16.2 Limit Management

The Limit Management displays the list with the following:
•	 Transaction – The function for which limits can be changed
•	 Currency – The currency for the functions
•	 Maximum Allowed Limit- Maximum Limit amount for the transaction each day
•	 Assigned Limit- Limit provided by the Bank/new limit after changed
•	 New Limit- New Limit user request to set
 

This page allows the corporate admin user to set a new limit which is lower than the maximum 
allowed limit. To change the daily limit, enter the New Limit in the corresponding input field.

You may set a daily transaction limit which is lower than the current limit. Limits updated 
successfully will be automatically reflected online. 

16 User Admin
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16.2 Limit Management

Suspend Users
This page allows the corporate admin to suspend any of the company’s assigned users.
 
Click Suspend User to display the Suspend User screen as shown below. The Corporate Admin can 
also search the specific users under the Search Users by keying in their User ID, Username and their 
User ID Statuses.

To suspend a user, select or tick the corresponding User and then click suspend. A confirmation page 
will display  the selected user that you have suspended. Click OK to proceed or Cancel to return to the 
list. 

Important: Once a user has been suspended, his/her access to b.Digital Business Banking will be 
disabled. The corporate admin shall need to inform Digital Banking should they wish to re-activate the 
user. 

16 User Admin
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17 Settings
17.1 Changing Passwords

Changing Passwords
From the menu, go to Settings → Change Password.
The Change Password screen should be displayed. Here, you can update your password.

Steps to changing your password

Step 1 
Under Current Password field, enter your current password.

Step 2
Under New Password field, enter your new password.

Step 3
Under Re-enter New Password field, enter your newly set password that was 
entered in the New Password field.

xyz company01235
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17 Settings
17.1 Changing Passwords

Step 4
Click the SAVE button. A confirmation message will be prompted 
and your password is now changed. 

Note:
There are requirements to setting or changing your password. Please refer to the following:

• Passwords are case sensitive. Your password needs to be alpha-numeric and have a minimum length
of at least 8 characters. It will need to contain at least 1 uppercase and 1 special character

• The newly set password needs to be different from at least 3 previously used passwords.
• What you enter under the New Password field and Re-enter New Password field needs to be identical.
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18 Baiduri b.Digital Business Mobile App
18.1 Login Screen

Download the app from App Store or Google Play Store.

Once downloaded, you can login with your Corporate Group ID, User ID and Password.
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18 Baiduri b.Digital Business Mobile App
18.2 Generate Digital Token

Step 1 
Tap on the menu on the top left 
corner of the screen.

Then tap Generate Secure Code. 

Step 2 
A secure code will then be displayed 
on the screen.

Enter this secure code on the 
2-Factor Authentication (2FA) screen 
on the Baiduri b.Digital Business web 
platform, where required.
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Once you have logged in, you will be able to view the dashboard.

The dashboard on this app is an optimized version of the web platform. 

You will only be able to view the following via the Baiduri b.Digital Business Mobile App:
•  Operative Accounts
•  Deposit Accounts
•  Loan Accounts

18 Baiduri b.Digital Business Mobile App
18.3 Dashboard

XYZ COMPANY
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18 Baiduri b.Digital Business Mobile App
18.3 Dashboard

You can view the statuses of transactions under the financial and non-financial 
transaction statistics table.

You can also send messages to the Digital Banking Team through the app.
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17.4 Send Message

Step 1 
User clicks on the Mail icon on 
the top upper right corner

Step 2 
User clicks on “New Message” 

Step 3
User selects Category, 
inputs the Subject and 
Message and click Send

XYZ COMPANY

18 Baiduri b.Digital Business Mobile App
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18.5 Manage Workflow

Step 1 
Transactions can be approved visa 
the mobile app by an Approver.

Go to the respective transaction 
that requires approval and select 
Manage Workflow. 

Step 2 
You can check and review details of 
a transaction before approving.

18 Baiduri b.Digital Business Mobile App
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